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 GuidosToolbox – Installation 
 

December 2023 
Peter Vogt, European Commission, Joint Research Centre (JRC), Ispra (VA), Italy 

 
This document provides installation instructions for the image analysis program GuidosToolbox 
(GTB). The 64bit software is available for Microsoft Windows, macOS, and Linux. Download it from 
the official home page: https://forest.jrc.ec.europa.eu/en/activities/lpa/gtb/.  
To ensure the package integrity, compare the md5sum against the GTB md5sum list.  
GTB is coded in and includes the IDL Virtual Machine and additional GIS-software (MSPA, GDAL, 
FWTools), which can be used to export your data as raster image overlays for visualization in Google 
Earth and to pre- or post-process any raster data. GTB is completely self-contained and fully 
functional in its own directory. It can be installed/copied to any directory on your system or any 
external device.   
 

General information: 
 

• System requirements: PC/Mac with a minimum of 4 GB RAM (the more the better) 
 

• Limitations: maximum image dimension in pixels:  
- to be loaded in GTB: 30,000 × 30,000,  
- for Contortion analysis: 5000 × 5000,  
- for MSPA-analysis: 10,000 × 10,000 on MS-Windows; larger on Linux/macOS and 

dynamically calculated depending on the amount of free RAM:  
~25,000 × 25,000 for 16GB RAM and 75,000 × 75,000 for 128GB RAM. Images larger 
than the maximum size for MSPA can be processed with GWB, more details in GTB under: 
Help → GTB Documentation → MSPA Guide  
 

• Upon the first start, the GTB license conditions will be displayed. Please read through this 
document and then click on Yes in the GTB startup check popup window to accept these 
conditions, which will permit GTB to start: 

 
 

mailto:peter.vogt@ec.europa.eu?subject=GuidosToolbox%20question
https://forest.jrc.ec.europa.eu/en/activities/lpa/gtb/
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/GTB_md5sums.txt
https://www.harrisgeospatial.com/Software-Technology/IDL
https://forest.jrc.ec.europa.eu/en/activities/lpa/mspa/
https://gdal.org/
http://fwtools.maptools.org/
https://www.google.com/earth/versions/
https://www.google.com/earth/versions/
https://forest.jrc.ec.europa.eu/en/activities/lpa/gwb/
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/MSPA_Guide.pdf
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• Upon each start, GTB will inform you if program or revision updates are available. Support will 
be provided for the current version only, so please ensure to use the current version. To install 
a revision release, start GTB and from the menu select: Help → GTB Online → Check for Updates 
and follow the instructions. 
 

• GTB workshop material: provides additional information, example applications, data sets and 
instructions to illustrate various processing options. To install, start GTB and from the menu 
select: Help → GTB Online → GWS and follow the instructions. 
 

• Should you find a bug while running GTB, please chose Help → Bug Report. Please scroll to the 
end of the bug report document and insert further details. This information may be helpful to 
replicate and hopefully fix the error you encountered.  

 
 
 
 
 
 

A) Installation on Microsoft-Windows (8.1 - 11, 64bit only): 
 

1) Download GTB_windows.exe to a local directory.  
 
2) Install GuidosToolbox to its default location C:\GuidosToolbox. The installation can be 
performed without administrator rights. If writing to the C-drive is not allowed the user can choose 
a different directory and the installer will setup a standalone directory GTB<version>. The 
standalone version has the same functionality as the default installation, but it will not provide any 
system integration, such as desktop shortcuts, menu entries or an uninstaller. To uninstall the 
standalone version simply delete the directory GTB<version>. 
 
3) Start GuidosToolbox with a double-click on the desktop launcher or from the start menu  
(Start → Programs → GuidosToolbox → GuidosToolbox). In case of the standalone version 
double-click the launcher startGTB. 
 
 

Note: 
⚫ If you get the error of a missing MSVCR100.dll then download and install the Microsoft 

Visual C++ Redistributable for 64bit: https://aka.ms/vs/17/release/vc_redist.x64.exe 
⚫ You can copy the installed directory GuidosToolbox to a USB-stick (FAT or NTFS) and then 

start GuidosToolbox or any additional included software component with a double-click on 
the respective startXX-launcher in the GuidosToolbox directory. 

⚫ GTB for MS-Windows 32-bit has been discontinued. The latest, unsupported version 2.702 
can be downloaded from the GTB homepage. 

  

https://docs.microsoft.com/en-US/cpp/windows/latest-supported-vc-redist?view=msvc-170
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B) Installation on macOS (min 10.10, Intel/Apple Silicon M CPU): 
 
1) Download the installer GTB_macOS.dmg to a local directory.   
                             
2) Delete any previous folder /Applications/GuidosToolbox and empty the Trash. 
 
3) Important: Ensure to have the latest version of XQuartz. After this, download the latest version 
of gdal-complete. Carefully read the gdal-complete instructions and first install the required latest 
version of Python 3.9. Then install gdal-complete. Verify that gdal works properly: Open a Terminal 
and enter: bash Next, enter the command: gdalinfo --version  

If gdal is not found, amend the $PATH environment variable by copy/pasting the following one-line 
sequence (the entire content marked in gray color) into the terminal, then hit the Enter key: 
echo 'export 
PATH=/Library/Frameworks/GDAL.framework/Programs:/Library/Frameworks/PROJ.framework/Programs:/Library/Frameworks/S
QLite3.framework/Programs:/Library/Frameworks/UnixImageIO.framework/Programs:$PATH' >> ~/.bashrc  

 
Then quit the Terminal. Note that this fix has to be applied only once. To verify, open a new Terminal 
and enter: bash Next, enter the command: gdalinfo --version and you should now see the following result: 
GDAL 3.2.2, released 2021/03/05 or any newer version once available. 
 
4) To install GTB, right-click the installer GTB_macOS.dmg and select: Open with → 
DiskImageMounter.app. Agree with the copyright conditions in the new popup window, then 
drag/drop GuidosToolbox to the folder /Applications, then exit and unmount the installer. 
 
5) Open the directory /Applications/GuidosToolbox, double-click, or right-click → Open 
GuidosToolbox.app to start the application. New security features first introduced in macOS 10.15 
(Catalina) may require your permission for GTB to modify files within the GTB folder and the system, 
meaning you may see some or all of these windows:  
 

  
 

  
 

You must click on OK to grant these permissions. If you accidently clicked on Don’t Allow then 
GuidosToolbox will no longer start. You can reset the permissions by opening a Terminal and enter 
the command: tccutil reset AppleEvents; tccutil reset SystemPolicyAllFiles 

https://www.xquartz.org/
https://www.kyngchaos.com/software/archive/gdal-complete/
https://www.python.org/downloads/
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Important Note:  
 

• Because I am not registered with Apple as an official ‘identified developer’ you will likely get 
a warning message that blocks the application. You can still run GTB by following the 
instructions on this Apple support page  or even better this page, which has more details, 
informative images and a step-by-step guidance:  

 
 

• If the default startup process fails with the following, or similar, error message:  

        
  

click on OK to close this window. Next, try to start the application using the alternative 
launch procedure: Open the directory /Applications/GuidosToolbox and double-click, or 
right-click → Open on the file: startGTB.command 
You may get further popup windows asking for permission to execute this command. Again, 
please allow the execution of this command for GTB to start up. 
The default startup process (via a double-click on GuidosToolbox.app) is not impacted by 
running the startGTB.command and hence, it may still fail.  
In this case, it is imperative to use the startGTB.command to start GTB. 

 
⚫ To add shortcuts to GTB and GTB Data on your desktop, please open the directory 

/Applications/GuidosToolbox and double-click on mkShortcuts 
 

⚫ OpenEV is not available in the macOS-version of GTB. 

https://support.apple.com/en-gb/guide/mac-help/mh40616/mac
https://www.macworld.com/article/672947/how-to-open-a-mac-app-from-an-unidentified-developer.html
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C) Installation on Linux:  

 
 

A) System-wide installation: 
 

GuidosToolbox can be installed for system-wide usage and made available to all users. Go to the 
GTB-Download section and follow the instructions on an updated current operating system: 

• PCLinuxOS: Open Synaptic and search for/install GuidosToolbox 

• Mageia: Download the package GTB-Mageia.x86_64.rpm to a local directory. From a root-
terminal enter the command:  
urpmi <full path to the downloaded GTB-Mageia.x86_64.rpm> 

• Fedora: Download the package GTB-Fedora.x86_64.rpm to a local directory. From a root-
terminal enter the command: yum install <full path to the downloaded GTB-Fedora.x86_64.rpm> 

• SUSE: Download the package GTB-Suse.x86_64.rpm to a local directory. From a root-terminal 
enter the command:  
zypper install --allow-unsigned-rpm <full path to the downloaded GTB-Suse.x86_64.rpm>  

• Debian/*buntu: Download the package gtb_amd64.deb to a local directory. From a root-
terminal enter the command: apt install <full path to the downloaded gtb_amd64.deb>.  

• Other Linux distributions: One of the above-mentioned rpm or deb-packages may work, if not 
use the standalone version outlined in the following section.  

 

Important note:  
On CentOS you first may have to install:  
wget http://packages.psychotic.ninja/7/testing/x86_64/RPMS/mupdf-1.10a-7.el7.psychotic.x86_64.rpm; yum install epel-release 
dnf-plugins-core <full path to the downloaded mupdf>  
 

 
 
 

B) Standalone installation (as normal user, not as root!):                       
 

1) Download the file GTB_linux64.run to your $HOME directory, i.e., /home/peter 
 
2) Open a terminal (konsole, xterm) in this directory and make the installer executable using the 
command: chmod u+x GTB_linux64.run 
 
3) Start the installer with the command: ./GTB_linux64.run and follow the instructions. The installer 
extracts the directory GuidosToolbox and creates two desktop launchers: GTB, GTB_Data.                                                                
 
4) Start GuidosToolbox in one of the following 3 ways: 
- double-click GTB on your desktop, or  
- double-click GTB.desktop in the directory GuidosToolbox, or  
- open a terminal in the directory GuidosToolbox and enter the command: ./startGTB.sh 

 
 
 

https://forest.jrc.ec.europa.eu/en/activities/lpa/gtb/#Download
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/GTB-Mageia.x86_64.rpm
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/GTB-Fedora.x86_64.rpm
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/GTB-Suse.x86_64.rpm
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/gtb_amd64.deb
http://packages.psychotic.ninja/7/testing/x86_64/RPMS/mupdf-1.10a-7.el7.psychotic.x86_64.rpm
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/GTB_linux64.run
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Note: 
 

⚫ If GTB fails to start, open your software package manager (Synaptic, aptitude, Yast, Yum, 
etc.) and install gdal, inxi, libgomp1 and the proj package and a reasonable pdf-reader 
application (e.g., mupdf). 
 

⚫ QGIS will be available from the GuidosToolbox menu if it is found in your system, or after it 
has been installed via your package manager of your Linux distribution.  
 

⚫ OpenEV is not available in the Linux version of GuidosToolbox. 
 

⚫ If you change the path/location of the GuidosToolbox directory (for example when running 
from a USB-flash drive or external USB-disk) you can start the program in the GuidosToolbox 
directory using the command ./startGTB.sh Alternatively, you can re-create the desktop-
launchers for the new location of this directory with the command ./makeLaunchers.sh and then 
copy the xx.desktop files to your desktop and click these to start the programs. 
 

⚫ GTB has been successfully tested on the following current and updated 64bit Linux 
distributions: Arch, CentOS, Debian, Fedora, Ubuntu, Mageia, Manjaro, Mint, SUSE, 
PCLinuxOS, RedHat.  
 

⚫ On Linux servers, please use the cmd-line only version GWB (GuidosToolbox Workbench) 
 

 
For best compatibility, please use the KDE desktop environment in PCLinuxOS.   

 
  

https://forest.jrc.ec.europa.eu/en/activities/lpa/gwb/
https://www.pclinuxos.com/
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GTB Quickstart: 
 

Please use the default (Geo-)Tiff data format whenever possible! 

 
GTB uses a sub-directory data for reading/saving images (also directly accessible from the desktop 
launcher) and a sample binary GeoTiff image input.tif is located in this directory data.  You can 
specify a different default data directory via File → Set Data Directory. Because some users 
encountered problems when using network data directories, local data directories are preferred.  

 
 
Do a quick test run: 
 
1) Start GTB in the operating system specific way described above. 
 
2) From the default data directory GuidosToolbox/data, load the sample image: File → Read Image 
→ GeoTiff, select input.tif, press Open. 
 
3) Perform a MSPA-analysis: Image Analysis → Pattern → Morphological → MSPA 
 
4) Save the result: File → Save Image → GeoTiff 
The MSPA-analysis of input.tif is saved to the default data directory GuidosToolbox/data. 
 
More information on the features of GuidosToolbox, the MSPA parameters and more is available 
from the Help menu in the GuidosToolbox Manual and the MSPA Guide. 
 
For other comments and suggestions please contact: Peter.Vogt@ec.europa.eu 

https://ies-ows.jrc.ec.europa.eu/gtb/GTB/GuidosToolbox_Manual.pdf
https://ies-ows.jrc.ec.europa.eu/gtb/GTB/MSPA_Guide.pdf
mailto:Peter.Vogt@ec.europa.eu?subject=GuidosToolbox%20question
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